Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Garming Forerunner ddl problem

in: Orienteering; Gear & Toys

Oct 13, 2016 8:23 PM # 
Having trouble dowloading the gpx file from Garmin Connect. It may be an issue with the site, but I fear it is more likely to be a corrupt source (the raw data/the .fit file).

Can anyone shed light on this?
Oct 13, 2016 10:10 PM # 
Have you tried turning it off and back on again?
Oct 14, 2016 1:36 AM # 
I had the problem on Friday - kept getting a 505 error message.
My techie son said the message indicated a server problem at their end.
I assumed it would be fixed by now.
Oct 14, 2016 2:03 AM # 
I have been getting that error for two weeks. Tried different browser and different computers. Problem is definitely on their end. I've had to use GPS babel to get my files directly out of my watch, or you can take the raw .fit file from GC and convert that to .gpx with
Oct 14, 2016 12:23 PM # 
I'd love to turn the Garmin site off and on again, tRicky, but my hacking skills are limited. But anyway, it's that I've been able to upload the sessions but not download a gpx track - got a 500 error message. The gpsies site did produce the desired result. Thaks jvincent.
Oct 14, 2016 2:40 PM # 
Just curious why folks are uploading to Garmin and then downloading GPX tracks?
Oct 14, 2016 3:58 PM # 
hughmac': Quickroute and Routegadget.
Oct 14, 2016 4:21 PM # 
Besides Quick Route and Route Gadget I have found uploading to Garmin and then downloading GPX tracks the simplest way to get my GPS tracks, used for some mapping tasks, from the GPS device to OCAD and/or OOM.
Oct 14, 2016 7:16 PM # 
I've had the same problem, and I've found that changing the permissions of who can view the data from just me to everyone allows me to export to gpx from Garmin connect. Unfortunately, this only works sometimes.
Oct 14, 2016 7:50 PM # 
My data goes to Garmin Connect automatically, but if I need a gpx file for something like routegadget I usually just pull it from the AP log... Have you tried that option?
Oct 14, 2016 10:15 PM # 
I get the same error on Garmin connect. I contacted Garmin Europe support and received this response:
Thank you for contacting Garmin Europe.
I am happy to assist.
The issue you are referring to is something that we are aware of and are working hard towards a resolution, however, we do not have a timeframe for this to be completed as yet.

When the issue has been corrected, the fix will be released in a software update. This will be announced on your Garmin Connect account or on Garmin Express. If, at that point you require further assistance please contact us via our Contact Centre whereby we will be happy to talk you through it.

I’m sorry for the inconvenience.
Oct 15, 2016 1:43 PM # 
What cmorse said: I find it a lot easier to find the files here at AP, too.
Oct 15, 2016 2:01 PM # 
thanks, mprg, I await the software up-date
Oct 15, 2016 4:25 PM # 
I've been using SportsTracks 3.1 for a few years downloading from my 305 and then exporting the gpx file which I then import into OCAD. No prpblems so far. I have used the free trial version which seems to have an unlimited life and has all the features I want.
Oct 15, 2016 7:26 PM # 
I manually sync my GC activities to my AP log, at which point I could pull a .gpx file out of it. Is there a way to make that push from GC to AP automatic?
Oct 16, 2016 1:55 AM # 
Yeah - tell Ken to pay Garmin about $5000.
Oct 16, 2016 1:05 PM # 
How do you manually sync GC activities to your AP log when GC shows errors when trying to export GPX and TCX files?
How does one stop a Forerunner that has been programmed to automatically send tracks to Garmin Connect and then delete them? Stop and then send the tracks elsewhere?
Is anyone else skeptical about that software update story. Surely something that broke without a software update can be fixed without one.
Oct 16, 2016 1:32 PM # 
Add Training > GC Web sync. Pulls directly from GC.

May well be a feature that only appears to paid AP supporters.
Oct 16, 2016 9:13 PM # 
Gord, the AP<-GC sync seems to work in spite of the export feature not working in GC. AP is probably pulling the .fit files. And yes, I too am skeptical about the fix coming in a software update.
Oct 21, 2016 12:33 PM # 
This seems to be fixed now
Oct 26, 2016 12:18 PM # 
I've seen the 505 error and have a love/have relationship with Garmin Connect / Express. It just never seems smooth.
The last few months my downloaded GPX files have has sporadic entries to S 0.0, W 0.0 (I've never been there and definitely not during a race).
The track looks fine while viewing in G.C. but when imported as a GPX to RG there are several line segments to S 0.0 W 0.0. I can edit the file and delete those entries and all goes back to normal but it's a pain.
Anyone else experience that?
Oct 26, 2016 3:17 PM # 
Len, I haven't had that problem.
Oct 26, 2016 3:36 PM # 
I just had this problem (the 505 error) on Sunday night. It would not let me export as tcx or gpx, but did let me choose the first option (without having it open, I believe it says something like export original). That produced a tcx file which I was able to convert to gpx via another site I use.

I was using Garmin Training Center with my 305, but that software now fails to open and produces an error message no matter what I do (repaired, uninstalled, reinstalled, un/reinstalled drivers...) Nothing else about my setup has changed and Garmin tech support was not very helpful. The number of ways to retrieve my data are growing very few.
Oct 27, 2016 8:20 PM # 
@furlong47: I've had good success with Garmin Express to upload to Garmin Connect, and then the AP Garmin Connect: ... but I don't have a 305 any longer to test with ...

Then once it's on AP I can grab the GPX file, if I need to, as well.

@Len: were those GPX files from GC, or AP? I had a 'jaggies' issue from the GC > AP GPX files, and @ken fixed things up on the AP side ... does an AP GPX file work better?
Oct 28, 2016 4:34 PM # 
They were from GC.
A sample is in the Hickory Run September event as I saved it before I knew what was going on.
Oct 28, 2016 5:22 PM # 
@Len: looks like the jaggies that @ken fixed ... I (before thinking) just deleted the route from DVOA RG, thinking I could get it from your AP log. Mind uploading to AP (syncing with GCsync would be best!) so I can test? But maybe you don't have this extended AP feature.
Oct 29, 2016 3:55 AM # 
I had those jaggies on Routegadget too, with the Garmin Express .gpx files. Assuming you mean the same thing. The whole route was made up of right angles and big chunky squarish things. If I downloaded the Garmin Express .tcx files and converted them to .gpx via my third party site, then the track looked normal.
Oct 29, 2016 7:21 AM # 
yes, jaggies appear on RG if there is 0,0 coordiantes in gpx file. It is a kind of resolution issue, I failed to see such files/points would be there. IIn future versions of RG points like that will be dropped.

I have been told Garmin Connect began to add points like that, maybe half year ago or so, to gpx exports of recordings made with some (older?) watch models. Points seem to be at the begining or end of file.

Now I am just guessing here, but I suspect is it may be some kind of timing offset issue, HR data not starting end ending at some time as gps track and because HR values are ettribures of track points they need to either drop those HR points or add artifical track points (with lat lon 0,0) for storing those HR values. But it may well be someting else.

I havent used garmin products for years so I never happenned to me personally, I have just heard horror stories and got some example gpx files.
Oct 29, 2016 10:37 PM # 
So Jagge, what gps do you use? I was just about to go buy a garmin when this thread started, but put that plan on hold while watching to see how this played out.
Nov 4, 2016 1:21 PM # 
I figured the blocky lines were a resolution thing and the route used up all the vertices going to 0,0 a bunch of times.
@HM4 I only download from my watch to GC, save as a GPX and import to Routegadget. I dont know of other ways... or haven't spent the time to look into them.
The weird thing is that the route looks fine as mapped in GC so its the saving to GPX that creates the problem. I see this issue all within Garmin.
Nov 4, 2016 11:27 PM # 
Terje Mathisen:
I think this is a fairly recent issue, I had never seen it before a couple of months ago.

I have a 620 with the latest firmware.
Nov 6, 2016 3:16 PM # 
Problem seems to be fixed at Garmin Connect (the ddl of gpx file)
Nov 8, 2016 1:37 AM # 
Agreed. gpx download appears to be fixed.
Nov 9, 2016 5:58 PM # 
Yayee. The last two files I downloaded Monday and they came in without problems :)

This discussion thread is closed.