Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Or program

in: Orienteering; General

Jun 30, 2021 11:58 PM # 
CarlB:
Or program is not recognizing the SI download box. Downloaded the driver from sport ident and still no joy. Have you experienced this and fix?
Advertisement  
Jul 1, 2021 1:07 AM # 
Hawkeye:
A couple of things you could try:
- connect another download box to see whether the problem is specific to that particular download box;
- check the operating mode in Config+ (should be "RDO-Readout SI-cards")

If it's just the problem download box that Or doesn't recognise, or if it's not recognised in Config+, you might have a problem with the USB cable.
Jul 1, 2021 3:19 AM # 
Mr Wonderful:
Your mileage may vary.

I had the same problem - MeOS, SI Config, etc. all could see the box, not so much Or.

After much anguished searching, I thought I read somewhere that the SI drivers are 32 bit, and you may have defaulted to installing just 64 bit java. I brawled with our club laptop for weeks before stumbling onto the right AP thread for that one, which inspired a 32 bit java install and now the club laptop is back to operational. At least I think that's what fixed it.
Jul 1, 2021 9:45 AM # 
CarlB:
The SI download box is recognized by the SPORTident Config+ program on the laptop but not the Or program. I will check the 64/32 bit Java install that is used to operate the Or program.
Jul 1, 2021 11:13 AM # 
Mr Wonderful:
This is not the thread I found, but it works even better perhaps.

https://www.attackpoint.org/discussionthread.jsp/m...
Jul 1, 2021 12:28 PM # 
Uncle JiM:
When using SI ConFig, what are the 'advanced settings' Is legacy protocol selected
Jul 1, 2021 6:40 PM # 
CarlB:
Uncle Jim it is not selected optional feedback and acoustical feedback are selected.
Jul 1, 2021 9:17 PM # 
martinflynn:
A couple of people have reported a similar problem. Updating their Java to the latest version seems to have sorted it out.
Jul 2, 2021 6:32 PM # 
GuyO:
Have a related, frustrating problem...
The apparent inability of the computer to communicate with the download box -- ie, accept downloads.

Using Or, it never gets past "Connecting"

Config+ seems to recognize the box, but clicking Read Card, or Settings results in errors messages along tbe lines of "Access denied", "Did not reply", "Too many errors", ...

I updated everything: SI driver, java, Or, Windows; to no effect.

Ideas??
Jul 4, 2021 3:53 PM # 
martinflynn:
Could you have some user privileges problem? I am not very familiar with how privileges work on Windows but maybe the drivers were installed as one user and you are trying to access as another.

The only suggestion I can make is to uninstall Config+ and make sure the SI driver is also uninstalled (uninstall manually if necessary). Then install just Config+ - it will also install the driver. If you are prompted, select the option "allow everybody to use".

Martin
Jul 4, 2021 6:06 PM # 
gordhun:
Guy, This may be a stupid question but have you tried all the COM ports suggested by the Or program?
My laptop has five choices offered up by Or. I never remember which USB port is which so a bit of trial and error goes on there. Four won't get a connection but one does.
But if you are able to get a connection for syncing the clocks in the timing boxes you should be able to use the same connection information.
Jul 5, 2021 8:07 PM # 
GuyO:
Thanks Martin & Gord,

Since I had posted here, I tried 2 other Win10 PCs, neither of which already had SI Config+, java, or Or, and the result was the same. It was working properly the day before this problem appeared -- which was before I was on-site, so I have no idea what might have happened in between working and not-working.

Gord: None of the 3 computers offered more than one port, COM3 or COM4.

Anyway, I'm going to send the download unit (BSM7) to HVO's equipment guru, for him to check out.
Jul 9, 2021 3:48 AM # 
GuyO:
Following-up...

As it turns out, the problem was that the download unit had "frozen"; it had nothing to do with Or.

Unfreezing it required opening the box, un-soldering the battery, then re-soldering it -- basically a complicated reboot. (A reset button would have helped)
Jul 9, 2021 7:34 AM # 
martinflynn:
Iirc, there are a pair of largish gold pads on the board. If you connect these with a wire briefly, it will reset the box.
Jul 9, 2021 2:50 PM # 
CHARLIE-B:
@GuyO you didn't install a reset button?
Jul 10, 2021 9:30 AM # 
GuyO:
@Charlie: LOL!!

Craig Weber is HVO's equipment / SI guru (among other things), so he did the un/re-soldering.

Please login to add a message.