Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: SplitsBrowser links to specific displays

in: Orienteering; General

Jan 11, 2018 2:27 PM # 
Florida Orienteering uses SplitsBrowser on its web site for study of splits from our events. I would like to add a direct link to a certain SplitsBrowser display to a web page, which I thought would be easy. Just tweak the settings on SplitsBrowser to show the display I want, then click the "Link" link at the top to produce a URL for those settings. But when I do that, I get the message:

SplitsBrowser – Error
Sorry, it wasn't possible to load the results data. The error message returned from the server was 'Not Found'.

The link to the overall event results works fine:

but the link generated for my specific display, e.g.,

doesn't. I've tried some variations on the generated URL, clipping different bits, but all variations produce the same error.

Anybody know why this is or what to do about it?

Blaik Mathews
Florida Orienteering
Jan 11, 2018 6:21 PM # 
Looking at the source, I see:


I have a feeling that that '.csv' at the end is ... incorrectly placed. It needs to be connected to the Results name, as in your default page for that event:


So there's something busted in your PHP file that sets this all up, or a bug in SplitsBrowser. I use RouteGadget and it works fine ... but I'm not loading the CSV like that, I guess.

Jan 11, 2018 7:31 PM # 
My first thought after poking at this a little was that your splitsbrowser.php script is broken and not accepting those extra parameters that the "Link" link is generating. So I went looking for SplitsBrowser source to see if I could verify that. But the source I found has no splitsbrowser.php in it. After some more googling I discovered that the author had previously told you that he doesn't know what that script is or even who wrote it.

So I think your issue is again not with SplitsBrowser but with the splitsbrowser.php script. You're going to need to either locate the author of that or else find someone who can look it over in their absence and determine if it needs to be updated to handle this use case.
Jan 11, 2018 8:12 PM # 

Looks like adding "csv?" before the first & will make it work despite the bug.

Please login to add a message.