Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Downloading Or to a Windows 10 computer

in: Orienteering; Gear & Toys

Jun 28, 2017 11:37 PM # 
eldersmith:
Has anyone had any success in downloading Or onto a computer using Windows 10? I've been trying to use the current version of Java, and using Internet Explorer 11 since it sounds on the web as if it's the only windows browser still allowing java plugins. I've tried following the FAQ's on the Or download website to configure the Java to accept interactions from their site, and I have tried to follow suggestions on the Java website about how to make sure the IE11 enables java scripts, but when I click on the launch Or tab on the Or website, i just get error messages. Any suggestions?
Advertisement  
Jun 29, 2017 1:27 AM # 
Juffy:
You know what tech support people love? People who say "I got errors" and don't say what the errors are. :)
Jun 29, 2017 1:29 AM # 
jjcote:
You know what users love? Error messages that don't say what the errors are. ;-)
Jun 29, 2017 1:31 AM # 
Juffy:
You know what tech support people love? Users who think that just because the error message means nothing to them, it'll mean nothing to tech support either. :p
Jun 29, 2017 5:07 PM # 
walk:
You don't seem to have gotten anything helpful yet. So jumping into the breach, yes - have Ór on Windows 10, downloaded with Firefox. Can't remember any issues but it has been running fine for about a year. Good luck with it. Hate those error messages (and the flack that comes with them from the peanut gallery. )
Jun 29, 2017 5:16 PM # 
eldersmith:
Thanks, George. Unfortunately, starting a few months ago, Firefox discontinued plugin support for Java, so from what I've been able to find, that is not supposed to now be a viable option.
Jun 29, 2017 5:45 PM # 
walk:
Bummer. Try contacting the webmaster. I have found that to be useful.
Jun 29, 2017 9:43 PM # 
P.Stromme:
Check out this thread: https://www.attackpoint.org/discussionthread.jsp/m...
Jun 30, 2017 4:16 AM # 
Delyn:
You aren't running it within your browser so support for java plugins shouldn't matter.

Use any browser, did you try another? The Launch Ór link it just a download of the or.jnlp file. Just click it. Tell us what error you get...

You can also right click the link and select save link as... or equivalent. Suspect your browser might be trying to run the file and not just download it. I do get a message using chrome that This file type may be harmful to your computer. That is because it is Java. Just continue, use Java files only from trusted sources.

From there you have the file downloaded on your computer. You will have to then follow the instruction for P.Stromme linked above or http://www.orienteering.ie/or-home/or-faq
Jun 30, 2017 9:01 AM # 
andrewd:
A screenshot of the error is worth a thousand words.
Jul 1, 2017 5:51 PM # 
eldersmith:
The error message I get is:
Unable to launch the application

When I click the details button, i get the statement
Unable to load resource: http://orienteering.ie/or/or.jnlp
Exception Wrapped exception

com.sun.deploy.net.FailedDownloadException: Unable to load resource: http://orienteering.ie/or/or.jnlp
at com.sun.deploy.net.DownloadEngine.actionDownload(U... Source)
at com.sun.deploy.net.DownloadEngine.downloadResource... Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main.access$000(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I would note that when I configure Java 8 to allow the security exception
http://orienteering.ie/or/or.jnlp as suggested by P.Stromme and also
http://oreinteering.ie as suggested on the download page , the process goes through smoothly on my old laptop running Vista, but not on the new one running Windows 10, though I think I went through an identical procedure on the Java configuration and I get the same thing showing up on the configuration screen afterwards.

I have tried running the launch Java link on the download website, and downloading the link as a link to my computer and clicking on the link there, doesn't seem to make any difference.
Jul 1, 2017 8:44 PM # 
hughmac⁴:
Worked fine for me on Win 10. As Delyn says, just right-click the link and Save as..., and save to your desktop, instead of trying to 'Launch' Or (they should really change the verbiage on the download page).

I just did (in Chrome, not that it matters):

  • http://orienteering.ie/or/or.jnlp <- right-clicked that URL and chose 'Save link as ...'
  • saved it to my desktop
  • from https://java.com/ installed latest Java
  • after install, per the FAQ went to Start > Configure Java > Security tab > 'Edit Site List' > Add > entered 'http://orienteering.ie/or' so I have a new line with that as an exception > OK > OK
  • double-clicked Or from the desktop

    Good luck!

    Re-looking at your reply, it looks like you are missing 'http://orienteering.ie/or' (note the /or at the end) as a Java Security Exception 'Site'. That should be all that you need.
  • Jul 1, 2017 11:49 PM # 
    eldersmith:
    Hi Hugh,

    I added your third alternative of the URL suggested on the FAQ page but with an extra /or tacked onto the end, Tried again. Same set of error messages.
    Jul 2, 2017 1:17 PM # 
    Juffy:
    Downloaded that JNLP file, zipped and uploaded here: http://www.pdowling.id.au/or.zip Try that?
    Jul 3, 2017 7:10 PM # 
    mprg:
    It works fine for me:
    Windows 10 Pro 64bit
    Java Version 8 update 131
    here are images of my java security settings:
    https://www.dropbox.com/sh/3d9k8c56959whkz/AABEKFy...

    My exception site list contains one entry: http://orienteering.ie
    Jul 3, 2017 8:26 PM # 
    martinflynn:
    One (remote?) possibility is that your PC is trying to use IPv6 to download the JNLP file for some reason:

    https://stackoverflow.com/questions/12535937/java-...

    I don't think orienteering.ie supports IPv6. It should be possible to insist on using IPv4:

    https://docs.oracle.com/javase/7/docs/api/java/net...

    I think the following should achieve this:
    1. Use the same Java control panel as you used to set the security exception.
    2. Click on the Java tab
    3. Select the version of Java you are using and click on the Runtime Parameters cell.
    4. Paste -Djava.net.preferIPv4Stack=true into it and click OK.
    5. Click Apply
    6. Click on the JNLP link

    An alternative may be to disable "Internet Protocol Version 6 (TCP/IPv6)" in the configuration for your internet connection.

    Martin
    Jul 4, 2017 4:54 PM # 
    eldersmith:
    Thanks, Martin!

    You seem to have hit the solution! Pasted in the line about preferring IPV4, and now everything seems to be working fine. I really appreciate the effort that people have put into finding the solution to my problem--the AP community is a great asset--as is Orienteering.ie!

    Please login to add a message.