Register | Login
Attackpoint - performance and training tools for orienteering athletes

Discussion: Purple Pen 3.0 Released

in: Orienteering; Gear & Toys

Apr 29, 2017 6:56 PM # 
petergolde:
For those who are interested in Course Setting/Control Description Software:

Purple Pen 3.0 has just been released. This version of Purple Pen has several major new features, including:

Direct (vector based) support for OpenOrienteering Mapper maps. You can load, view, print, and export to OpenOrienteering Mapper maps in the same was as OCAD maps. Full vector fidelity is maintained.

Course Variations and Relays: You can now add forks or loops into courses, creating courses with variations. When you have a course with variations, Purple Pen can automatically assign variations to relay team members.

64-bit Support: Purple Pen automatically runs in 64-bit mode when possible, allowing large bitmaps to be used as base maps.

Much improved PDF support: When using a PDF file as the base map for course design, compatibility is much better, especially for PDFs produced by OCAD. Downloading and installing GPL GhostScript is no longer required.

Many other smaller features and bug fixes are also included. If you haven't checked out Purple Pen recently, you might want to give it a new look.

As always, Purple Pen is free (although donations are appreciated if you like and use the software!), and runs on Windows (XP through 10). Translation is included for 15+ languages.

Download at http://purple-pen.org
Advertisement  
Apr 30, 2017 4:40 AM # 
o-maps:
Mac version someday?
Apr 30, 2017 7:44 PM # 
petergolde:
Feels like iOS or Android would be a more forward-looking choice, if making the effort to port to a new platform. And VirtualBox is not a bad solution for the Mac. The effort to port to a new UI framework, and more importantly, keep them in sync, is substantial. So I wouldn't hold your breath.
May 1, 2017 2:00 AM # 
Becks:
Echoing the iOS support Unconnected to this tried to run PP on Bootcamp today and got the weirdest problem of all time - map doesn't zoom well and then when you try to place a start symbol, it acts like a paintbrush in old school MS paint....except it reveals another version of the map!

If anyone has had this problem you'll know what I mean - have you ever solved it?
May 1, 2017 4:40 PM # 
petergolde:
Not seen that, and I've used Bootcamp extensively for Purple Pen.

If it's a retina-level screen try running in a lower resolution and set screen scaling down to 100%. If you have a weird display driver issue that might help.
May 1, 2017 8:37 PM # 
toddp:
Thank you Peter, those features sound like great additions to an already great application.

Please login to add a message.